Jump to content
  • Cresent.jpg

Carib Inn

XPH10

Recommended Posts

Hello - first post. I  have a new XPH10 cordless hammer drill that suddenly will no longer run but the light does come. Switch tests OK. Battery  fine. I am not getting any voltage to the brushes. There is a small rectangular piece about 1/8 thick attached to a heat sink which sits under the motor. 3 black wires go to it. There is continuity through all wires so none are burnt. I have a feeling that is what is wrong but can not find that part in any schematic. What is it? Any other ideas?  Can't send it back. I live in the Caribbean and it will cost more than the drill is

worth.Thank you   Bruce

Share this post


Link to post
Share on other sites

Motor controller transistor. The one currently installed in the drill should have a product code which you can search to find a replacement. They're quite cheap to replace.

 

If you have continuity at all three points it most likely is faulty.

 

It doesn't have its own item code on the spares catalogue, however. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Member Statistics

    13,979
    Total Members
    414
    Most Online
    ZacharyDrumm
    Newest Member
    ZacharyDrumm
    Joined
×
×
  • Create New...