Jump to content
Sign in to follow this  
gyrobob

Ryobi Gas Pressure Washer won't idle

Recommended Posts

I bought a ryobi RY80940B with a Honda idle down engine in July 2018.  I used it a few times and it worked really well.  Started instantly every time.  In September I used it the last time, and put some sta-bil in the gas tank, ran it for a while, then put some Briggs and Stratton pump saver in the pump before putting the thing in the shed.  It has maybe 10 hours on it.

 

Today I wanted to use it, but it took about 50 pulls to get it started, and I needed ether to get it to fire at all.  Now it won't idle down.  It surges when  the pressure washer pump is pumping, but when you stop pressure washing the engine just slows down to a slow idle for a second, then stops.

 

It is acting as if it has been stored for a few years with no fuel stabilizer.

 

I don't want to have to take off the carb and clean it out, but I will if I can not get it to work.  I'm hoping someone here has a quick tip on how to make this thing work like it used to.

 

I am also thinking about using the warranty to have it fixed or replaced, but that is about as much a pain as taking the carb off and cleaning it, which I could do in an hour.

ryobi pr wash 01.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Member Statistics

    12,868
    Total Members
    414
    Most Online
    Jamie Winter
    Newest Member
    Jamie Winter
    Joined
×