Jump to content
  • Cresent.jpg

LADave

automotive vacuum pump

Recommended Posts

I have a hand-operated vacuum pump/gauge for testing purposes and brake fluid changes.  It has lost its ability to pull a vacuum, apparently because the plunger part no longer seals against cylinder walls. How can I fix this?  Should I try using cooking oil or silicone spray?  I'm concerned that cooking oil might cause deterioration in any rubber parts.

Share this post


Link to post
Share on other sites

Welcome to the forum.

 

My speculation is that usage during brake fluid changes caused an accidental fluid intrusion into the pump.

 

The fix would be disassembly and o-ring replacement. It might be possible to match at the local hardware store. The manufacturer might offer a replacement.

 

Mine is decades old and still pulls a vacuum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Member Statistics

    13,979
    Total Members
    414
    Most Online
    ZacharyDrumm
    Newest Member
    ZacharyDrumm
    Joined
×
×
  • Create New...