Jump to content
Sign in to follow this  
sirsawsalot

I am on my third ... saw. but theres tears in my beer

Recommended Posts

tears really.

Now my 3rd 20V B&D 12" LCS1020 saw has just stopped running. First one lasted longest, purchased 10/12/15 with its original 2.0 Ah (LBXR2020) battery and a B&D branded (LBZX4020-OPE) 4.0 Ah battery.  

Then stuff got ugly. I bought a Powerextra 5.0A 20V MAX battery advertised as compatible on 7/8/18.. 

Smoke show.

The worst smell you ever did NOT want to smell coming from the MOTOR of your machine. Most intense right from the cooling vents near the motor.

I did get that tree down in 1 cut.

Powerxtra did compensate me for the battery and the saw, but in the mean time you know, tears... beers.  

I call(ed) that one my little chain buddy. 

I got a new little Chainey, and bought another 4.0 Ah Munikind battery later in the summer of 18.

 

Pretty much smooth sailing and gentle cuts with lots of breaks, but I did get a whiff of that same smell now and then in the meantime, the one that gives me a tight feeling in my gut,c cause you know something is wrong.

 

I opened the side cover of first one and did not see anything I could do for the poor thing. What can I do now? Out of warranty, no new battery to blame. I dint even remember which battery made the saw smell burny. 

Is there a sacrificial part that keeps giving up the ghost THAT I CAN REPLACE?

An electric fuseable link?

check continuity where?

It can't be the motor, I mean really, the motor goes first? Never. 

For all the great things electricity can do I am not a super expert although I can use a voltmeter and a soldering iron. my grandfather taught me that. He was the "best radio man in Worcester County" in 1940.

 

Share this post


Link to post
Share on other sites

the red wire has continuity from the battery terminal to the motor if I hold the switch. The black ground goes into a circuit board, but I can't get continuity from battery terminal to motor.

Share this post


Link to post
Share on other sites

I finally got the case halves apart. And Looked at all the wires. The switch is on the red leads, the black (and yellow) go to a circuit board. The smell maybe is coming from the motor. I have my original saw apart, and the electrical burning smell may have dissipated somewhat over the last year. There is no obvious damage to the IC board.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Member Statistics

    14,298
    Total Members
    414
    Most Online
    DMK68
    Newest Member
    DMK68
    Joined
×
×
  • Create New...