Jump to content

Search the Community

Showing results for tags 'broken'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the TIA forums
    • About the forums
    • What's New
    • Introduce yourself
  • Tools
    • Power Tool News
    • Power Tools
    • Power Tools By Manufacturer
    • Hand Tools
    • Test & Measurement
    • Accessories
    • Outdoor Power Equipment
    • Power Tool Recalls
  • Workplace
    • Around The House
    • In The Shop
    • Woodworking
    • Welding/Metal Working
    • Automotive
  • Tool Exchange
    • Ultimate Tool Bag Giveaway
    • Member Giveaways
    • TIA Swap Meet
    • Tool Deals
  • General
    • Pub Talk
    • Collector's Resource
    • How To
    • Site Help & Feedback

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Favorite Tool or Brand


Hobbies


Facebook


YouTube


Twitter


Google+


Other


First Name


Location:


Occupation

Found 2 results

  1. New to forum, seeking answer to problem with Makita X2 LXT 10" cordless compound miter saw. Have been working with tool for almost a year, have put it through its paces and cut all kinds of bevels with it. Today it got stuck at 22.5 degress (right side) and I can't get it to budge. I suspect the lock release button is somehow broken or jammed. I took off the back plastic housing hoping to get at it, but it turns out I'd have to do more disassembly to access it. Has anyone had this problem? I've been deep Team Blue for ten years but this is causing me to reconsider my loyalties. Brought my job
  2. Hello all, I’m after your friendly professional opinion here, I’ve recenty bought a Makita LS1018l Compound Mitre Saw, as recent as a week ago to be exact. the saw has had about 20 mins total run time since I’ve had, from new. I was cutting widths on a 4x4 yesterday to cut out a mortise and had it running for around 3 minutes off and on, off and on for around 10 seconds each time and smoke appeared out of the motor vents and it stunk. Now it won’t turn back on, even after cooling down as that was my initial thought, so I checked out the brushes and they lo
×
×
  • Create New...