Jump to content

Battery fuel gauge not working?


Turner85

Recommended Posts

So as the title says, the fuel gauge no longer works on one of my 5ah battery packs and i am wondering has it happened to anyone else and if its an easy repair or if people think im better off dropping it to repair centre. Its not under warranty as ive no receipt. 

Also can anyone tell me the type of bit i need for removing the screws, is it t10 security bit

  • Like 1
Link to comment
Share on other sites

Just now, Turner85 said:

So as the title says, the fuel gauge no longer works on one of my 5ah battery packs and i am wondering has it happened to anyone else and if its an easy repair or if people think im better off dropping it to repair centre. Its not under warranty as ive no receipt

there is no need for receipt with Milwaukee products they will go by date of Manufacture so unless you got a 5.0 battery long before they came out you should be good....lol

  • Like 1
Link to comment
Share on other sites

Just now, comp56 said:

there is no need for receipt with Milwaukee products they will go by date of Manufacture so unless you got a 5.0 battery long before they came out you should be good....lol

Thanks Comp but this is Dewalt and I am in Ireland where we have one official dewalt repair centre which ive heard a few horror stories about.

Link to comment
Share on other sites

4 minutes ago, DaveJr. said:

Did you try contacting DeWalt?

I believe i did once before for something and the only choice i had here in Ireland was going through this power tool supplier that basically works out of a hardware store, hes the official dewalt repair centre and i left my number with him numerous times for different things and he never once got back to me.

Link to comment
Share on other sites

2 minutes ago, KnarlyCarl said:

What comps saying is switch to Milwaukee and you'll be good hahaha!

Also use s t10 security bit for that screw since it's a t10 security screw !!

Sent from my XT1585 using Tapatalk

Id get festool for a similar price to milwaukee here ha,

i was thinking it might be just dust causing the issue because i had the faulty battery on my multitool cutting plasterboard when the issue occurred as far as i remember so was thinking just opening and cleaning it out would resolve it. 

 

Link to comment
Share on other sites

Dewalt will send you ONE battery complimentary, im not sure how true that is after ONE but they'll definitely send ONE as I just got off the phone with them and they'll be sending me a dcb205.

  • Like 1
Link to comment
Share on other sites

3 hours ago, Turner85 said:

I emailed them and response was just the battery is only covered for one year after that they can't do anything.

Sent from my SM-G900F using Tapatalk

damn i spose its different there in ireland, suppose you can call and talk to someone.

Link to comment
Share on other sites

That sucks dude :( In the usa its 2 years on slimpacks and 3 years on fat packs. I think they need to bump the warranty on battery packs though it should be like 3 slim packs and 4 on fat packs or maybe something prorated. The only good thing you can find decent knockoff packs now if your really desperate.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    16,557
    Total Members
    6,555
    Most Online
    marcel7979
    Newest Member
    marcel7979
    Joined
×
×
  • Create New...