Jump to content

I think I got a dud Nailer


Milwaukee_man_stan

Recommended Posts

Well yesterday I bought the M18 fuel 15 ga nailer Kit from my HD...

And when I opened it I charged the battery on my 6 bay rapid charger,got a different battery put some 34 deg. 15 ga nails into it and powered it on and it wouldn't shoot at all the LED didn't respond either read the manual front to back looked for videos switched batteries and no one seems to have this trouble. so I'm taking it back.

Link to comment
Share on other sites

1 hour ago, dwain said:

Are you sure it's powered on? You have to hold the power button down for a while (about 4 seconds), and reasonably hard too. Then a green light comes on ....


Sent from my iPhone using Tapatalk

Yes the green light came on after holding the power button for 4 seconds or so...

thanks for the reply though

Link to comment
Share on other sites

3 hours ago, Daniel Julian said:

Assuming you probably already know this, but the tip has to be fully depressed or it will not fire. Or if there are less than something like 5-10 nails, it won't fire.

Yep fully loaded the nailer and still didn't fire

Anyways got it swapped for a new nailer that works, and that 15 ga sure is amazing I feel cool O0

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...