Jump to content

DeWalt 54V XR FLEXVOLT 305mm Mitre Saw


M FLYNN

Recommended Posts

Hi  

I’m just wondering if anybody else is having a problem with the dewalt flexvolt 12” mitre saw? The problem I have come across is when the power adapter is used with a dust extractor. When the vacuum is switched to tool mode it starts straight away and will not turn off, the saw still works but to stop the vacuum you have to turn it off manually (will not shut off as supposed to). The vacuum is fine it works with all other corded tools.  

Any information will be appreciated. 

 

Cheers 

Michael 

Link to comment
Share on other sites

4 hours ago, Mordekyle said:

Does it have a timer where the vacuum remains in for 10 seconds after the saw is shut off?


Sent from my iPhone using Tapatalk

 

Hi mate thanks for the reply, yes that’s what happens with all my other tools. 

Not With the dewalt saw tho, when it is shut off the vacuum stays on.  

Link to comment
Share on other sites

  • 1 year later...

Have had three of these saws, all have had a problem and the final one blew up , gone back and I’ve had a full credit.

worked fine with batteries, then when power pack was connected it sounded awful,.

when 110 v power pack was connected it wouldn’t work with festool hoover, found out that a standard 110 v transformer wasn’t powerful enough to run both( useless)

save your money, Dewalt haven’t got it right, shame really as I’ve had the old models before and they were fine

Link to comment
Share on other sites

  • 11 months later...
On 6/24/2019 at 10:04 PM, Steveo said:

Have had three of these saws, all have had a problem and the final one blew up , gone back and I’ve had a full credit.

worked fine with batteries, then when power pack was connected it sounded awful,.

when 110 v power pack was connected it wouldn’t work with festool hoover, found out that a standard 110 v transformer wasn’t powerful enough to run both( useless)

save your money, Dewalt haven’t got it right, shame really as I’ve had the old models before and they were fine

Just sent my one back as it also stopped working when i put the 110 adapter on

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    17,435
    Total Members
    6,555
    Most Online
    JoeF
    Newest Member
    JoeF
    Joined
×
×
  • Create New...