Jump to content

New Blade Problem


Recommended Posts

I have a DW716XPS compound miter saw and recently switched the stock blade with a Freud Diablo D12100X. I changed the blade but didn't use the saw right away. Just used it for the first time since the change and have the following problems:

 

1. Shadow guide from the saw is off by about 3/8"

2. Blade does seem to cut perfectly straight even though the saw appears to be aligned properly

 

I was cutting wood flooring material (cherry) and was getting quite a bit of splinting, unless I moved extremely slow through the cut (much slower than you would consider normal). Blade is supposed to be good at not splintering wood; not sure if anyone has experience with these blades.

 

Appreciate any help.

 

By the way, I am not a professional, but have done quite a few home improvement projects with this saw and didn't have these issues with the stock blade.

Link to post
Share on other sites

You can put blue tape where you want to make the cut.

You can cut face side down, preferably if you put some zero clearance tape from Fastcap on the saw.


You can also score the board first- make a shallow cut all the way across the face before bringing the blade down.

Not real familiar with adjusting the light.


Sent from my iPhone using Tapatalk

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    14,894
    Total Members
    859
    Most Online
    CharlesMG
    Newest Member
    CharlesMG
    Joined
×
×
  • Create New...