Jump to content

ryobi leafblower problem


Recommended Posts

Im trying to get my neighbors ryobi bp42 leafblower running.He got it from someone for free,it didnt run.The air filter new,new spark plug,and fresh fuel added.The coil was also replaced since it was cheap money.You can crank it until your arm is tired and nothing happens.Did a compression test got 75 psi,cant find an actual spec.Did notice that the top of the piston and cylinder walls were very clean.Im thinking its a motor problem but i need other ideas.

Link to post
Share on other sites
On 6/5/2020 at 2:27 PM, DR99 said:

The Carburetor is most likely gummed up from sitting its a side effect of ethanol in gas.

sprayed fuel mix thru the carburetor and into the spark plug hole nothing happens did find ryobi forum site that said there were problems with the rings seizing causing a no start ever hear of this problem

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    14,877
    Total Members
    859
    Most Online
    BlueStreak
    Newest Member
    BlueStreak
    Joined
×
×
  • Create New...