Jump to content

AcDelco ARM602-3 3/8" Digital Torque Adapter not measuring torque


Recommended Posts

Hi,

I can choose the measurement units and the type of measurement, torque or peak on the screen. When I apply strength on it, no measurement and no sound. 

I changed the batteries, no change, still does not work. I opened it, can't see any loose wire, disconnected wire or connector. The only thing is the top seal that is broken in half.

A friend tells me that what you see within the yellow circle is a sign of water that got in probably by the broken seal.

Any suggestion on what can be done here? 

Thanks,

Michel.

 

image.png.b8d42f8506839d68ddec5ef458030550.png20201005_155218.thumb.jpg.8cf1bd021205975c583a3a674c05ed11.jpg1429804068_Tracedeau.thumb.jpg.776268e5449b9159e56e948e17f161e0.jpg20201005_154903.thumb.jpg.bae399170ac93382e3f19b267381c8b8.jpg

 

 

Edited by MChevrier
New info
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    14,733
    Total Members
    414
    Most Online
    Kozak88
    Newest Member
    Kozak88
    Joined
×
×
  • Create New...