Jump to content

DW 744 XRS Table Saw Paint Chipping


guy_86

Recommended Posts

Hi everyone new to this site glad to have forums like this when you need it.

My Table saw that i purchased 3 months ago with the rolling stand is working great, but the other day during a cut

the table itself which the wood slides across started  to chip off in where the wood wasnt even in contact with. Now it is

only getting worse through the vibrations each time i use the table saw. Anyone else even come across this problem, i have emailed Dewalts customer service and i am waiting to hear back from them. Let me know if anyone has ever had this happen to them thanks.

Link to comment
Share on other sites

I have a veteran DW744 that is 6yrs old, it look's far worse than that. I think it's a slip-coating that is used on top to help the material slide easier. I've used it some pretty rough, and nasty materials! Plywood covered in dirt, and ice, etc... Don't know if I'd classify the peeling as normal, but mine is pretty much all rubbed off.

I would wait to hear back from Dewalt on the matter.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    16,568
    Total Members
    6,555
    Most Online
    accentpainting91
    Newest Member
    accentpainting91
    Joined
×
×
  • Create New...