Jump to content

porter cable cordless drill lost variable speed, smells hot


spacoli

Recommended Posts

I have a porter cable 19.2 model # 884 cordless drill. When I pull the trigger it run at high speed only and it smells hot. I'm figuring it is the switch trigger and was planning on buying one but the cost is $56. I wanted to ask around and see if that is the problem? Any thoughts or suggestions would be greatly appreciated. thanks

Link to comment
Share on other sites

It could be the trigger switch or the actually motor, copper coils. Does the gun get hot? It does sound like it could be a trigger switch, but usually my experiences is that a bad trigger switch will cause the drill to cut on and off. But again it does sound like maybe the switch is getting stuck on the high speed and not bouncing back. Try to take the drill apart, if you know how and can put it back togther. Maybe it just has dust or a build up off something on the switch system and can be cleaned off.

Link to comment
Share on other sites

Thanks for your reply. I have taken it apart already. I'm not sure what is inside the acutal switch, but it seems to be mechanically working fine with nothing being stuck. I put a volt meter on the switch. While pushing the trigger the reading is either 0 or 18.8v (batteries are old).

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Member Statistics

    16,993
    Total Members
    6,555
    Most Online
    Cobia98
    Newest Member
    Cobia98
    Joined
×
×
  • Create New...