Jump to content

Help My M12 Batteries are dead?


goose77

Recommended Posts

I have the M12 sawzall, driver and inspection camera. I dont use them much recently I went to use them and they would not charge? Both lights on on the charger were just flashing. I have 2 chargers and 5 batteries I have tried mixing and matching them and nothing?? This is driving me crazy I cant believe all the batteries died at once, has anyone else had this issue? any fixes?

Thanks

Link to comment
Share on other sites

I had the exact same issue with mine. I hardly used them, I go to use them and get the same error. I figured out a work around , I used my my M12 flash light and ran my batteries down low not all the way though. After that they charged but I still get that error every so often.

Hope this helps

Link to comment
Share on other sites

  • 2 months later...
  • 10 months later...
Guest
This topic is now closed to further replies.
  • Member Statistics

    16,984
    Total Members
    6,555
    Most Online
    Toyyorky
    Newest Member
    Toyyorky
    Joined
×
×
  • Create New...