Jump to content

Is my Ryobi SDS-Max ED-450E rotary hammer drill 240v/50hz or 110v/50hz (its not 120v/60hz for the US/Canada)?


DermotM

Recommended Posts

Hi, I have been given an old Ryobi SDS-Max rotary hammer drill, ED-450E (for UK/Europe).


The plug is missing & label is damaged & i need to know whether it is 220-240v/50hz or 110v/50hz (yellow plug for construction sites, its definitely NOT 120v/60hz for the US.
From the Parts Lists & diagrams I've found there seems to be no distinction between the 110v & 240v models & the brochure dosen't list the voltages.

 

I asked Ryobi Technical if the ED-450E is a dual voltage drill & therefore all spare parts are the compatible (except the plug & label); and if not, how can I tell which model & also which parts to order?

The response was from Ryobi Technical was "...the wire in the power cord of a 110v machine tend to be thicker then that of a 240v. The only way it can be confirmed is by being inspected by a power tool repair shop. Parts for this machine can be bought from..."

 

...no use at all...:angry:...Can u help at all?
Many thanks

Ryobi_ED-450E_1.jpg

Link to comment
Share on other sites

Welcome aboard, glad to have you here!

I'll tell you my only experience with this is having come across fan motors which were installed by DIY guys and they were 220v motors on 110v equipment. The motors turned at half speed, but I'm not sure if there was any damage to the motor itself because of it. I'm sure there is a way to tell if you can take it to a motor repair shop and get a professional to look at it.

If you want to have a check yourself, open up the casing on the tool and see if there are any internal parts that have either voltage marking, maybe printed on the trigger switch.

I would probably plug it into a 110 volt outlet and see how it operates, and from experience, I would know if it was working right or not, it would be sluggish and not turn very fast. Since it was free, there's nothing to lose doing that, but only do it for a second or two, you will know right away whether or not that's the voltage it can use

Sent from my SCH-I535 using Tapatalk

  • Like 1
Link to comment
Share on other sites

Thanks for the advice guys,

Stripped down the motor & found a 100V stamp on the stator (nothing on the rotor/armature).
 Refurbished the carbon brushes, cleaned her down, put her back together, wired a 110v plug on & plugged her into a beat up old Davenset 3kva transformer...


RESULT!!!

 

Bit sparky at the brushes to start with but now seems to be working @ full power, plenty of juice. The inards of the pointy end need some work but thats for another day!

I got in touch with a parts/repair company to see (cjsinclairltd, very helpful) who were able to tell me:
- the 110v is discontinued
- the only parts lists & diagrams available to them also is almost certainly 240v
- of the 240v parts most of the service parts are discontinued...
So even if it had been a 240v I might not have been able to get parts.

 

To be honest though, I was hoping it was 240v: carting around a transformer is a PITA & I don't work on sites. I can get 240v Stators (£35) & Rotors/Armature (£72) to change it over but without the 110v parts list/diagram to compare with I don't know which other parts I'd need to change?!
Ho hum

Ryobi Ed-450E_Rotor_Armature_and_Stator_Coil.jpg

Ryobi Ed-450E_Stator_Coil.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    16,000
    Total Members
    5,540
    Most Online
    zerotwo
    Newest Member
    zerotwo
    Joined
×
×
  • Create New...