Jump to content

Dewalt 7 1/4" cordless Saw , DCS570


Twoply

Recommended Posts

When I try to use it, it just starts, and shuts off. 

 

It makes a soft grinding sound and shuts off after about a half blade revolution. 

 

The little LED lights turns on when I press the trigger.

 

I can rotate the blade and it makes the same grinding noise. 

 

Not a sharp metal on metal grind, almost like a hard plastic on hard plastic - dull grinding.

 

It gets fresh battery and still the same.

 

I've removed the spindle assembly and it still does the same. No loose metal in there to indicate a stripped gear.

 

I dont think the armature fins are dragging on anything.  

 

I did notice a wire's insulation was rubbed raw. As I separated all the wires, it started to run for about 2 revolution, then die again. 

 

The battery almost feels like it's drained because it will stop even trying after a few tries.

 

If I let it rest, it will start again.

 

The little black resister gets pretty hot while I'm attempting to operate this thing.

 

Help!

 

Thanks in advance.

  • Sad 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    17,428
    Total Members
    6,555
    Most Online
    JoeF
    Newest Member
    JoeF
    Joined
×
×
  • Create New...