Jump to content

Gen2 and Gen3 hammer drill quirks? LED going on and off constantly


fluidmindorg

Recommended Posts

Hi all. Forgive me if these are obvious, but I just recently decided to switch to Milwaukee cordless tools (after using DeWalts for years) so I'm unfamiliar with them. The first tool I got was the M18 FUEL Surge Impact Driver and I love it!

 

Q1: Is the electric clutch this bad on all the Gen3 Hammer Drill/Drivers?

After the Impact driver, I got a Gen3 Hammer Drill/Driver and came upon serious disappointment. The first thing I used it for was driving in a few small screws on a very low torque setting and it stripped the screws. Then I drove a few larger screws in and it drove them in way too far—still on a low setting. The clutch just wasn't doing what it was supposed to do, even down on a setting of 2. That was a deal breaker for me; I depend on that clutch for a lot of small screws going into soft wood. I only found one video on YouTube where someone talked about this problem, and I haven't been able to find anyone else mention it. Does anyone else have this problem with the 2804? Is this a serious flaw in this model? And if so, does anyone know if Milwaukee is planning on going back to the mechanical clutch for the Gen 4?

 

Q2: Does the LED keep going on and off on all the Gen2 Hammer Drill/Drivers?

Then I saw an old video from Vince at the VCG Construction YouTube channel demonstrating that the clutch on the Gen 2704 worked the way it's supposed to, so I got one of those. It worked great, with one odd quirk (to me anyway): when not in use the LED light goes on for 10 seconds, off for 30 seconds, on for 10, off for 30, and on and on like that without being touched. I thought it was a defect, so I called Milwaukee and spoke with someone in their tech support. She said she thought it was an electrical problem and that I should return it. So I returned it and order one from someone else. It arrived yesterday and does the same thing! That got me to wondering, is it designed to do that? I looked in the manual and it says nothing about that. I did finally notice, however, that if I put the direction switch on LOCK the LED stays off. Is this normal for the 2704? I can't find anything that mentions this odd LED behavior.

 

Thanks

--Dan

 

 

Link to comment
Share on other sites

  • fluidmindorg changed the title to Gen2 and Gen3 hammer drill quirks? LED going on and off constantly
  • 8 months later...

I will be happy to wait for answers to this question together with you. I am currently arranging my house myself and am looking for any information about lighting in the house and the car as a backlight in the cabin. The only thing that I have found so far is one site that I often see as advice from different people, and even my friends confirm the high quality of their products. I'm thinking of ordering an ecopac led driver from the site itself since I think this is precisely what I need; you can also watch something on this service if you are interested. Regarding your post, it will be exciting for me to see the answers of people who understand this area.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    17,535
    Total Members
    6,555
    Most Online
    JoeF
    Newest Member
    JoeF
    Joined
×
×
  • Create New...