Jump to content

Siphon Not Picking Up Fluid


Recommended Posts

I have a Ryobi GCV 190 power washer.  Recently I decided to use it to power wash my house which has vinyl siding.  Over the past decades from when it was installed, it has become dingy with green growth on the shady sides.  When I used the power washer on the one-story garage, the soaping setting on the nozzle worked as expected.  When I added a 35 ft. Ryobi hose extension, it did not pick up any cleaning fluid from the reservoir.  When I switched back to just using the original hose alone, it picked up cleaning fluid as before.  Is there any remedy for this?

Link to comment
Share on other sites

Welcome to the forum.

 

My speculation is that the added hose increases the pressure, preventing the venturi effect from drawing fluid.

 

Is there a less restrictive nozzle available for using when adding the extension hose?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    17,416
    Total Members
    6,555
    Most Online
    JoeF
    Newest Member
    JoeF
    Joined
×
×
  • Create New...