Jump to content

There's your problem


NicholasShetley

Recommended Posts

We finally found why my dads truck had an intermittent misfire. We had our new plugs and wires on it but it would still miss occasionally. I had noticed that the driver side valve train was making a lot of noise. We pulled the valve cover off and found a broken valve spring. The outer spring was broken in half and the inner spring was broken in three pieces. Luckily my dad had some extras for it laying around and we replaced it no problem. I also took a video of it running without a valve cover on it. I figured you guys might like the video. I'll upload it in just a bit and post it here when it's done.

image.jpeg

image.jpeg

  • Like 6
Link to comment
Share on other sites

5 minutes ago, Stercorarius said:

That's odd of comp to drop a product line like that.

It turns out that they just updated the design. I guess that these were the pro magnums and now they are the ultra pro magnums. They still offer a lifetime warranty though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Member Statistics

    17,316
    Total Members
    6,555
    Most Online
    JohnB
    Newest Member
    JohnB
    Joined
×
×
  • Create New...